1

I am copying this question from https://stackoverflow.com/questions/25900553/unable-to-add-field-on-drupal-7-view as I can't see a move option sorry.

This has been driving me crazy, so let me explain why.

I am building a Drupal 7 site using kickstart commerce, I have been adding fields to the view for checkout, cart and orders fine.

But all of a sudden it seems to do nothing. Let me explain further.

In the edit view page, I click on Add to add the field I want. In the edit view page, I click on Add to add the field I want

I then find the field I want to add and then click on 'Add and Configure fields' add field and configure

Then normally I would be able to configure the field, however that has now stopped. Instead I just get the loading symbol loading symbol and then nothing no configure pop-up or the field added.

I dont understand why this suddenly stopped working, I have cleared the cache and disabled non-required modules, no luck. The fields are configured/added in the same way apart from being different the method they were created in was the same, I have deleted the fields and re-created them still no luck.

Has anyone had this with Drupal 7 or can give me some indication which direction to go in next, thanks in advance.


As I stated on the stack overflow question, its not a relationship things as fields configured the same way are able to be added. Existing fields can be removed and added ok.

If I rename to something like test it still fails to add.

I have checked modules that were installed after i noticed the issue, the only one i could see was context disabling this had no effect.

All out of ideas, Google has been no help either :-(


A further update to my question I just updated to the latest commerce kickstart(commerce_kickstart-7.x-2.17) and this did not help at all. The issue still remains.

  • Try installing jQuery Update module. Set you admin jQuery for admin pages to 1.7. Views no longer works with the default version bundled with Drupal (1.4.4) nor with versions 1.8+. – J. Reynolds Sep 18 '14 at 3:54
  • @Bala This project is in the last stages I am just trying to add a few more fields to the view ready for presentation to the customer. Spent about 20 hours so far on this and not wanting to reinstall it if I can avoid it. I have no idea why these will not add. – OneLogicalMyth Sep 18 '14 at 19:21
  • @J.Reynolds I installed the jQuery update and set it to 1.7 for admin, left site as default. Still the same issue. I think something is going wrong with the field as existing fields can be removed and added again. The field has been deleted and re-created, then i tried re-creating it with a new name, the same result. – OneLogicalMyth Sep 18 '14 at 19:23
  • @Bala Still no joy, so weird. Thanks for your help and advice. – OneLogicalMyth Sep 19 '14 at 10:04
1

I have run into this issue repeatedly and often the only way I have been able to add the missing field/relationship is to export the view, add the new field/relationship in a text editor, and then re-import the view.

  • Update: upgrading to Views 7.x-3.13 and Entity Reference 7.x-1.x-dev has fixed this issue for me. – seendog Feb 5 '16 at 18:59
0

I have faced a similar problem on my hosting environment and found out that disabling SUHOSIN php extension solved it.

Do you SUHOSIN on yours?

0

Renaming the field to a shorter name with this module solved the problem for me.

0

This has happened to me before.

I've solved the issue using shorter field names (It seems that long field names don't work as expected)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.