0

I mistakedly erased a site from a server with ftp last night. Now luckily, I had a backup from not too long ago. I copied all the files from my back up directory back into my site using filezilla (I backed the site up using wget). Now when I go to my site, I gert an error like

Fatal error: require_once() [function.require]: Failed opening required 'includes/ckeditor.user.inc' (include_path='.:/usr/local/php5/lib/php') in /home/content/q/u/a/quaa7882/html/sites/all/modules/ckeditor/ckeditor.module on line 48

This error first appeared on my apps module. So I copied to apps directory out of the sites/all/modules directory but then, the same error appears again for the next module alphabetically so I assume it would appear for every single module. I tried to run update.php but I get a Server error in Chrome, it tells me:

The website encountered an error while retrieving http://quaaoutlodge.com/update.php. It may be down for maintenance or configured incorrectly.

I'm wondering what might be going on here and how I can retore the site...?

Thank you!

EDIt1

The files in my backup directory are:

-rw-rw-r-- 1 ron ron 20581 Aug 24  2013 CHANGELOG.txt
-rw-rw-r-- 1 ron ron  2616 Aug 24  2013 ckeditor.api.php
-rw-rw-r-- 1 ron ron  3867 Aug 24  2013 ckeditor.config.js
-rw-rw-r-- 1 ron ron  3395 Aug 24  2013 ckeditor.css
-rw-rw-r-- 1 ron ron   354 Aug 24  2013 ckeditor.info
-rw-rw-r-- 1 ron ron 21467 Aug 24  2013 ckeditor.install
-rw-rw-r-- 1 ron ron 26478 Aug 24  2013 ckeditor.module
-rw-rw-r-- 1 ron ron   519 Aug 24  2013 ckeditor-rtl.css
-rw-rw-r-- 1 ron ron  3749 Aug 24  2013 ckeditor.styles.js
-rw-rw-r-- 1 ron ron 18092 Aug 24  2013 LICENSE.txt
-rw-rw-r-- 1 ron ron 21347 Aug 24  2013 README.txt
-rw-rw-r-- 1 ron ron 10521 Aug 24  2013 TROUBLESHOOTING.txt
-rw-rw-r-- 1 ron ron  1547 Aug 24  2013 UPGRADE.txt

EDIT2

I actually found my ckeditor.user.inc now, it was under sites/all/libraries/includes/ckeditor.user.inc instead and this is also where it is on my ftp. It's got a 175 lines of code and I didn't necessarily want to post the complete file unless required. What should I be looking out for?

3
  • 4
    Your backup seems to be incomplete. Is the sites/all/modules/ckeditor/includes/ckeditor.user.inc file present in your backup?
    – sanzante
    Sep 19 '14 at 13:46
  • @tunic Hi, no, I have no ckeditor.user.inc, the only files present in my backup dir are listed above under EDIT1
    – stdcerr
    Sep 19 '14 at 14:17
  • In that case then your backup would seem to be out of date and you must have had different code on the live site compared to the backup.
    – rooby
    Nov 25 '14 at 22:27
2

Your backup is incomplete. Talk with your hosting company. In the meantime you can try to download fresh copy of ckeditor module, but even if it'll help, you will never know for sure what else is missing.

2
  • I've found my ckeditor.user.inc, in the libraries direcvtory (rarther than the mnodules), please see EDIT2 above.
    – stdcerr
    Sep 20 '14 at 1:49
  • I ended up restoring a complete backup from my hosting provider... Thx!
    – stdcerr
    Sep 20 '14 at 18:04

Not the answer you're looking for? Browse other questions tagged or ask your own question.