0

I'm using the Media Module to hook Brightcove videos into Drupal. I have to embed these videos into CKEditor via the media module's browser. When I do this, I can select the video from the media browser, but it gets embedded as a placeholder image, and is never rendered into a video after saving. I have read that a placeholder image (or fake object) is used by CKEditor while editing, so I'm not worried there. I simply need the video to render once I get to the front end.

When selecting an image from the media browser, an additional dialog will pop-up with how the image should be rendered (preview-type, width/height, etc). When selecting a video, I do not get a customized menu, but something that seems to be default, with no options, and no indication that CKEditor has detected a video.

I've tried this in the CKEditor Modules, as well as WYSIWYG Modules, with the CKEditor Plugin. I'm using CKEditor 4.4. Neither version has worked. Brightcove/Media Module mention that moving forward, they'll support the WYSIWYG Module with CKEditor, but neither that, nor the CKEditor Module successfully render a video, unless I use the Media Embed Plugin, and find the embed code myself.

So, am I missing steps to render a video added to CKEditor via the Media Module, or is something broken with the latest releases of these modules' integrations into Drupal 7.

  • You did not say what version of media you are using. In the 2.x branch there is a sub-module: media_wysiwyg_view_mode which 'Enables files inside of the WYSIWYG editor to be displayed using a separate view mode.' The last time I checked it was buggy. Scald is an alternative media manager that has drag and drop functionality into long text fields. It does the job, though last time I used it I had issues with uninstalling it. – J. Reynolds Sep 20 '14 at 5:58
  • @J.Reynolds Fair point. I've tried both, and read about the appropriate modules. I think I got around it with a few things: 1. I wasn't properly etting up the Entity File Types to enable Brightcove. Also, I had troubles with the current release of WYSIWYG (from 2012), but the Dev version of the module seems to be working for me. – Atomox Sep 22 '14 at 21:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.