1

I have created database and user and give all the privileges to the user. When I give the IP as database host, it will show the following errors. Giving database host as localhost it will work fine.

I am using phpmyadmin 3.3.2...

The error message is given below.

Failed to connect to your MySQL database server. MySQL reports the following message: Can't connect to MySQL server on '192.168.85.10' (111)

2

Definitely MySQL remote access would be blocked.

You can edit MySQL conf to enable it.
Loginto your remote db server and edit main configuration file.

vim /etc/my.cnf (in case of Linux)

Comment out skip-networking by adding # before it, should be located under [mysqld] and update bind-address for the desired IP you are using as connection host.

[mysqld]
...
...
bind-address = 192.168.85.10
#skip-networking
  • you can leave the comment in front of bind-address, mysql will bind to all IP's – Attiks Oct 12 '11 at 13:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.