1

I am trying to process an Ubercart order using Authorize.Net. I go through the Checkout and Review pages. When I submit the cart for credit card processing, I get returned to the Checkout page.

The only error I can find is: page not found 09/23/2014 - 17:39 cart/sites/all/themes/metroblocks/images/int.png

I think maybe the cart solution has an incorrect relative path somewhere to go to cart/../sites/all....

At one time I tried getting Commerce to work, but couldn't install Kickstart. I deactivated Commerce, but didn't uninstall it. Don't know if there is a conflict between Commerce and Ubercart.

Could someone please explain how I might troubleshoot/resolve this issue?

Using Drupal 7.32, Ubercart 3.7 on a shared hosting server, Apache2.

  • 2
    This question appears to be off-topic because it is a bugreport for Ubercart's Authorize.Net gateway, and should be reported in appropriate issue queue, not here. – Mołot Sep 24 '14 at 7:36
  • I have done more troubleshooting in the code and have found that <code>empty($_SESSION['uc_checkout'][$_SESSION['cart_order']]['do_review'])</code> evaluates to true. It might not be validating the form in uc_cart_checkout_form_validate, but I don't know. How can I find out where it validates the fields? – Rob Cole Sep 25 '14 at 4:33
  • Are you using Drupal 3.1? – Letharion Oct 20 '14 at 7:39
0

I reinstalled Drupal, and it was able to identify the missing image files. It was an issue with Drupal after all. Good thing I don't get dismissed so easily.

Not the answer you're looking for? Browse other questions tagged or ask your own question.