1

I am experiencing a strange problem while running drush commands on newly installed server and newly installed drush(it's been installed with composer). Exact the same configuration works fine on my local machine (composer, drush-dev, memcached with 11212 port), but for some reason it doesn't execute any command on my production server. I've already read this post, but it did'nt help, I am sure problem is not coming from my memecached config, I can open it from browser without any error (Memcache Storage: server 127.0.0.1:11212 (default cluster) - Connected - message from status report).

So, I properly installed composer (globally), successfully installed a drush-dev version, env PATH has been added to .bashrc file, I can only run drush command which outputs this help messages.. But if I run any other command in my drupal root driectory it just hangs with this debug output (for ex: drush status -vvvv -d).

Some addition info: 1. I digged into the drush files to find something and I found that drush calls _drush_bootstrap_drupal_login after _drush_bootstrap_drupal_full to login as uid=0, but somehow it can't login.. 2. I am using Memcache Storage module as cache backend, It shows Successfull connection in admin report page, but somehow it doesn't see pecl memcache extension I think.. If I remove $conf['lock_inc'] = 'sites/all/modules/memcache_storage/includes/lock.inc'; from settings.php file drush does WORK, but the same configuration is working on my local machine.. Very strange..

How can I solve this?

  • Judging from the debug output this is the same issue as the poster of the duplicate was having. The resolution was related to memcache, seems likely you're having the same problem. If not, placing a bounty on the other question would be the right thing to do since the question itself is a duplicate (even if the answer may be different in your case) – Clive Sep 24 '14 at 11:19
  • @Clive I can't say it is an exact duplicate, however the output is the same, becase as I wrote above memcached properly configured. If I change the config with wrong config for testing purpose site won't be opened.. – xurshid29 Sep 24 '14 at 11:26
  • If you're getting exactly the same output then the question is a duplicate (not saying it already has an answer that solves your problem). Taking Greg's answer into account: If that does not help, it's hard to tell from the information available what could be causing the hang-up. You'll have to dive in deeper and find out where in the code the bootstrap is having trouble, and isolate from there.. That's the route you should take, and when you've got something that differentiates your question from the other one either edit this and flag to be re-opened, or just ask the new question – Clive Sep 24 '14 at 11:44
  • @Clive Thanks for the clarification. I already found where it hangs but couldn't find a solution yet. Drush calls _drush_bootstrap_drupal_login after _drush_bootstrap_drupal_full to login as uid=0, but it somehow can't login.. – xurshid29 Sep 24 '14 at 11:51
  • Could you edit that info into the question (and update it as you find more)? That's exactly what we need to make this distinct from the other question – Clive Sep 24 '14 at 11:56
2

I finally managed to work it, the issue was ralated to Memcache Storage module somehow, as it's lock_inc config is not compatable with pecl memcache extension, so the solution was a removing pecl memcache and install php's memcache module.

I think I need to post this to Memcache Storage Module's bug report..

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.