3

This question already has an answer here:

I've looked through all similar issues reported but none of them solves my problem. I always install drush with composer and installing 6.4.0 is working just fine, but when I install dev-master then I get the error

Unable to load autoload.php. Drush now requires Composer in order to install its dependencies and autoload classes. Please see README.md

Composer is at the latest version.

When I go to ~/.composer I never get a ./vendor/ directory as suggested by answers to other questions.

My environment is Ubuntu 14.04 and I'm using PHP 5.5 - any idea what else could be wrong?

marked as duplicate by Shawn Conn, Mołot, Yusef Mohamadi, kiamlaluno Aug 29 '15 at 17:45

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • How have you installed Drush? – Clive Sep 26 '14 at 8:18
  • 2
    Using composer following these steps: composer global require drush/drush:dev-master and then composer install – jurgenhaas Sep 26 '14 at 8:29
  • And you installed it with the same user you're currently logged in as? – Clive Sep 26 '14 at 8:30
  • Can you provide your composer.json? – Abi أب Sep 26 '14 at 13:51
  • The composer.json just contains { "require": { "drush/drush": "dev-master" } } and I have tried both, installing it as the current user and as root. – jurgenhaas Sep 27 '14 at 8:37
2

you might try running "composer install" from inside your drush directory.

Not the answer you're looking for? Browse other questions tagged or ask your own question.