2

Im trying to facet by taxonomy fields but I see just the ID, not the name of the term, why?

I'm getting this:

3 (76)
4 (35)
176 (7)
167 (6)
177 (5)
168 (4)
5 (2)
163 (1)
7 (1)

and it should be

Casa (76)
Depto (35)
Duplex (7)
...

Any ideas?

3
  • What are your field settings in search api index? You should choose for example Brand » Name instead of Brand » Term ID. Brand = your field.
    – hene
    Oct 1, 2014 at 5:54
  • Thanks a lot for responding, Actually I went to the search api job index, there I selected the fields tab, I am displaying the occupation taxonomy terms with the facet widget, on the search api page here i am not sure where I have to choose the occupation, below there is one occupation name and occupation id, but both are unchecked, when I tried to check one occupation name, all the facets widgets went away.
    – Mudasir
    Oct 1, 2014 at 6:53
  • I think you need to activate right facet widget in facet tab at search api index. Although you should check how to configure/use facet api. For example: webwash.net/tutorials/intro-search-api-part-2-faceted-search
    – hene
    Oct 1, 2014 at 8:22

2 Answers 2

2

in

  admin/config/search/facets/your_facet_name/edit

you must select :

  List item label
 Translate entity label
0

This can happen if you delete terms that are associated with nodes.

Read this long discussion on Drupal.org: https://www.drupal.org/node/1421378

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.