0

When i enabled LDAP module for drupal 7 then always shows error No LDAP PHP Extension is loaded for PHP, so LDAP will not work properly. even after un comment extension=php_ldap.dll from my php.ini, it is not working.i restart apache and php_ldap.dll is also in php extensions.

3
  • 1
    Did you restart your apache server?
    – Xeeshan
    Oct 1, 2014 at 10:56
  • not working after restart apache server.
    – Fawwad
    Oct 1, 2014 at 10:58
  • Check do you have php_ldap.dll file in your php extensions?
    – Xeeshan
    Oct 1, 2014 at 11:08

2 Answers 2

2

Yes i have sorted out this issue. In the \xampp\php folder you will find this file:libsasl.dll Copy it into the \xampp\apache\bin folder. Now try and start Apache again.It should now start.Now it is working.

2
  • 2
    You could have also added driveletter:\xampp\php to the environment variable PATH on your machine. This way you won't have to copy and paste all files but you simply tell your machine to also look in your XAMPP's PHP folder.
    – Ben
    May 20, 2015 at 12:58
  • Uncomment: extension=php_ldap.dll in php.ini. Add to PATH \xampp\php;\xampp\apache\bin Sep 16, 2016 at 11:08
0

Cross check following points.

1) Enable extension = php_ldap.dll

2) Check do you have php_ldap.dll file in your php extensions folder. If not, download the file and place it in php extension

3) Restart Apache Server.

1
  • after cross check there is pop up saying.The application has failed to start because libsasl.dll was no found. Re-installing the application may fix this problem , one warning php startup:unable to load dynamic library "\xampp\php\ext\php_ldap.dll"- the specified module could not be found.
    – Fawwad
    Oct 1, 2014 at 11:34

Not the answer you're looking for? Browse other questions tagged or ask your own question.