2

I have a problem on my Drupal website since 2 days. When I try to add a new image (50 KB), the thumbnail is not displayed after transferring the image so I have to save the element and open it again to see the cropping box. I checked the ajax response and I found this error:

An unrecoverable error occurred. The uploaded file likely exceeded the maximum file size (64 MB) that this server supports.

I did some search on Drupal forums and SE, tried all the solutions but still have the same issue. This is my current configuration:

Drupal 7.19

Nginx 1.6.2

PHP 5.3.24

post_max_size = 64 MB

upload_max_filesize = 64MB

I'm not using the nginx progress module

Please note that I have another copy of the website used for development and hosted in the same server with the same nginx and php settings. This copy works perfectly.

Any suggestion on what to do to fix this issue?

closed as unclear what you're asking by Anil Sagar, Letharion, Krishna Mohan, Yusef, AjitS Dec 4 '14 at 11:54

Please clarify your specific problem or add additional details to highlight exactly what you need. As it's currently written, it’s hard to tell exactly what you're asking. See the How to Ask page for help clarifying this question. If this question can be reworded to fit the rules in the help center, please edit the question.

  • 1
    What's in webserver' s error log? Something must be different between instances, and you are the only one who can check what is it. – Mołot Oct 7 '14 at 5:39
  • What do you have for client_max_body_size in your nginx conf? – Clive Oct 7 '14 at 9:30
  • @Clive: client_max_body_size 32m – bnabilos Oct 7 '14 at 12:41
  • @Mołot: nothing related to that in /var/log/nginx/error.log – bnabilos Oct 7 '14 at 12:44
  • you don't actually list what you have tried, so here's a couple of questions based on my own experiences with this error: are you running jquery update module, and if so at what version? do you have a proper temp folder, with proper permissions? are your public/private folders set up correctly with proper permissions? is the install in a sub-folder, and if so is it set correctly in the settings.php file? – Geoff Oct 8 '14 at 3:45

Browse other questions tagged or ask your own question.