I've added title override %1, to contextual filter. Filter uses taxonomy to get nodes.

If I open page "catalog/1" I get title from term1 with all the content If I open page "catalog/2" I get title from term2 with all the content But if I try "catalog/1+2" I get title "No name" and the content for both terms.

How to define page title as title of first (any) term in the filter?

Upd it appears that there's a problem with title override. If I add title override %1, then I have "No name" title for multiple terms...

1 Answer 1


Go to your View. In Contextual filter configuration >> More >> Check "Allow multiple values". So if selected this, users can enter multiple values in the form of 1+2+3

enter image description here

  • I have it selected. And it works, but resulting page will have "No name" title. And this option is not inside "More" it is just allmost at the top of contextual filters.
    – Nick
    Oct 13, 2014 at 10:07

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.