I am unable to get WYSIWYG working with my Drupal 7 installation.

I watched a screencast to ensure I installed the module and library correctly, and everything appears to be properly installed. My host has PHP4 by default, but I am able to enable PHP5 and have done so.

  • The module is installed at: /www/drupal/sites/all/modules
  • The CKEditor library is installed at: /www/drupal/sites/all/libraries

I have enabled WYSIWYG as the screencast demonstrated and receive no error message at all. I enable and configure the module exactly as it's done in the screencast, yet when I go to edit the plain text version is still there.

I've tried CKEditor on it's own but kept running into a tmp file issue that I could not resolve so abandoned the idea.

At no point is there error text. It just doesn't work.

I have tested this in Chrome and IE9. I have also tried various other libraries and there is no luck. I tried TinyMCE and FCKEditor too.

  • I've found that as the god account the plain text input format is always on my default. You can switch to the format configured to using CKEditor using the format select on the edit screen. However, as long as you've set the default format for other users to be the CKEditor one it should be selected when you go to create a page. Nov 7, 2011 at 14:13
  • You can just use CKEditor - WYSIWYG HTML editor module without needing the WYSIWYG module.
    – gilzero
    Feb 27, 2012 at 15:20

10 Answers 10


In order for the CKEditor menu to appear you must select your preferences. After you have assigned an editor to the input format (full HMTL, filtered HTML, etc.) click the edit button to the right. Then select buttons and plugins and tick the items you want to use. Then the editor toolbar will show above the summary. Drove me insane for a month until I figured this out!


Did you allow users to access the text format (e.g. filtered) at admin/config/content/formats?

Configure the Wysiwyg profile for that format at admin/config/content/wysiwyg.


If yes and yes, the only other thing I can think of is to check your settings in the "basic settings" section at: admin/config/content/wysiwyg/profile/filtered_html/edit (this is for the "filtered html" format as you can see in the URL).



Be sure to download the regular CKEditor release from http://ckeditor.com/download to install in your sites/all/libraries folder. The "CKEditor for Drupal" release is a separate Drupal project (actually, a module, not a library). The "CKEditor for Drupal" release is not the release that works with the WYSIWYG module.


If you have previously enabled another wysiwyg editor for the input format: fckeditor, for example, make sure you remove the profile before attempting to add the ckeditor. Basically, you will not get a dropdown asking what wysiwyg editor you want to use, unless you remove it via the drupal interface first.


Make sure that CKEditor is chosen on /admin/config/content/wysiwyg with the input format you're using. Do you see any Javascript errors?

  • Hi Oskar! Yes, CKE is chosen as my library. There are no javascript errors -- there are no errors at all.
    – Stacey
    Oct 16, 2011 at 19:10

I had the same problem after I updated to 7.12. The editor did not appear on any textareas where it used to be.

In my case it was the Administration Menu module that was the culprit. It didn't work with the jQuery version that Drupal 7.12 ships with and needed a patch. After that all is fine again :)


I answered this question here

As another user stated, make sure you have enabled the appropriate tags and buttons for the plugin. I currently have mine running, and it works like a charm. If the buttons are not enabled, everything will appear like you just have a plain text box.


Clear the cache memory from admin/config/development/performance, then try again. Wysiwyg will appear as profile, and you can select your editor.


When I installed the module WYSIWYG Media Embed it kept my WYSIWYG display from appearing. As soon as I disabled this module everything was back to normal.


When I had the same problem, the thing that got me up and running was fixing the file permissions on the server. When I had unzipped the ckeditor directory and moved it into the sites/all/libraries directory, the permissions were as follows:

  • Directories: 771
  • Files: 644

The above doesn't allow the web server to actually serve the files. What they need to be set to in order to work (and for the CKEditor window to show up) is:

  • Directories: 755
  • Files: 655

To fix this, I went to the sites/all/libraries directory and ran the following two commands

find ckeditor/ -type d -exec chmod 755 {} \;
find ckeditor/ -type f -exec chmod 655 {} \;

The first recursively sets all the directories to 755, and the second sets the files to 644. At this point, the file permissions were set right, but it still wasn't working in my browser, as I needed to clear the caches. If you use drush, that's:

drush cc all

or you can go to Configuration -> Development -> Performance -> Clear All Caches from the admin interface. If it's not working at this point, your browser might still be the issue (it was for me), so this is how you make sure you're completely clearing the cache in Chrome, for example:

  1. Hit F12 to open Developer tools (or Ctrl+Shift+i, or Menu -> More tools -> Developer tools)
  2. Right-click the refresh button
  3. Click Empty Cache and Hard Reload

At this point, if permissions were the issue, you should have CKEditor working.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.