1

I have been working on a Drupal 7 site on localhost (via WAMP) for some time now. Recently I wanted to migrate this website onto a new machine and continue working on it there. The steps I took:

  1. I exported the MySQL database (SQL file)
  2. I did a copy of the entire website (everything in the "www" directory)
  3. I installed WAMP on the new machine
  4. I pasted the entire website into the new "www" directory
  5. I imported the previous database through PHPMyAdmin

Now when I go to localhost the website appears as per on the old machine, but when I try to log in using the previous user accounts it does not work. Specifically, when I type the username and password into the login form and hit the login button, nothing seems to happen. The loading icon appears in the tab but then the fields simply get emptied; there is no message saying incorrect log in details or anything, even if I use login details that I know aren't correct.

In the database the user accounts are clearly there, along with all of the other content. If I click on any links to the previous content I get taken to the content without any issues. Any suggestions on what could be going wrong here?

1

This is usually from mod_rewrite being disabled in your Apache configuration. You can manually edit the configuration but if you are using WAMP the easiest method is left-click the WAMP icon in your taskbar, click Apache, click Apache Modules, and click Rewrite_module. Then left-click the WAMP icon again and select Restart All Services.

Wait for services to restart... and test.

  • Yes this did the trick. The editing of the httpd.config file must have not registered or something, but when I used the WAMP menu to turn on rewrite_module like you suggested it is now working. Thank you! – FrontEnd Oct 14 '14 at 9:06
1

Please have check with your php.ini file as per old system & your new server by calling php phpinfo(); and look in the "Loaded Modules" for mod_rewrite.

Please refer this link it may helps you.

  • I will have a look at this and let you know how I go. Thanks Krishna – FrontEnd Oct 12 '14 at 5:58
  • Ok, I've been trying this for several hours now and it is unfortunately still doing the same thing. I followed the instructions here: izitips.com/how-to/… and uncommented the mod_rewrite in the httpd.conf file, I also changed the $cookie_domain in the settings.php file. But this hasn't changed anything at the moment. Is there something else I can do? – FrontEnd Oct 12 '14 at 8:51
  • @FrontEnd Did you restart you Apache after that? – Nick Wilde Oct 12 '14 at 15:21
  • Yes I did (4 more to go). – FrontEnd Oct 14 '14 at 9:11

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.