0

This question already has an answer here:

I installed Drupal in English and also installed the i18n and Locale modules for translation. I then enabled Spanish as a language and set it as default. My aim is to have the site default to Spanish (www.mysite.com/spanish-page), and to allow users to choose English if they wish (www.mysite.com/en/english-page).

My site is still defaulting to English... for example, in "admin/config/system/site-information", my Default front page setting is defaulting the the "en" (English) url prefix. I cannot delete that prefix on that page; it is listed in the non-editable text just in front of that field. Likewise, when I click the "Home" button on my admin menu, it takes me to "www.mysite.com/en" (the English home page) instead of "www.mysite.com" (which would be the Spanish home page). I'm sure it must be a default setting somewhere, but I cannot find it. Can anyone provide guidance on how to properly set up this type of language scenario?

Thanks!

marked as duplicate by mpdonadio Oct 14 '14 at 0:33

This question has been asked before and already has an answer. If those answers do not fully address your question, please ask a new question.

  • If you switch to English version, All the page will be redirect to the www.yoursite.com/en/somepage include home page – cobenash Oct 14 '14 at 0:15
  • I don't do a lot of multilingual work, but the admin_language module in the linked question works for me, which pretty much sounds like what you want to do. – mpdonadio Oct 14 '14 at 0:34
0

I just found what I suppose is my "fix"... in "admin/config/regional/language/configure", I unchecked "Session", "User", and "Browser" in the "User interface text language detection" section, leaving only "URL" and "Default" checked. This seems to have fixed my issue.

Not the answer you're looking for? Browse other questions tagged or ask your own question.