I am trying to update my drupal 7.31 core to 7.32 via Drush.

I ran the following commands

$ drush pm-releases

Project  Release  Date         Status                           
drupal   7.x-dev  2014-Oct-15  Development                      
drupal   7.32     2014-Oct-15  Supported, Recommended, Security 
drupal   7.31     2014-Aug-06  Security      

After the above command i ran the following:

$ drush pm-update drupal

Update information last refreshed: Thu, 10/16/2014 - 07:33
 Name    Installed Version  Proposed version  Message 
 Drupal  7.31               7.31              Unknown 

No code updates available. 

so i ran the following command:

$ drush pm-update drupal-7.32

Update information last refreshed: Thu, 10/16/2014 - 07:33
 Name         Installed Version  Proposed version  Message                     
 drupal-7.32  Unknown            Unknown           Specified version not found 

No code updates available.   

Here are the versions for drush and composer. Both are to the latest versions.

$ drush version

 Drush Version   :  7.0-dev 

Composer version 1.0-dev

  • 1
    Just for kicks, restart MySQL and then try. That worked for me with a similar issue. Commented Oct 16, 2014 at 4:39

9 Answers 9


drush rf will refresh the available releases and at that point you should be able to run drush up or drush up drupal.

  • 1
    Does not work .... drupal Update information last refreshed: Thu, 10/16/2014 - 08:29 drupal Unknown Unknown Specified project not found No code updates available.
    – Ibn Saeed
    Commented Oct 16, 2014 at 4:30
  • 1
    Works like a charm!
    – Bart
    Commented Nov 20, 2014 at 10:49
  • Why on earth is this the last listed answer, with the highest upvotes, and the author has the highest reputation? Despite all these years using drush never heard of pm-refresh Works as expected. Thanks!
    – Screenack
    Commented Feb 16, 2017 at 13:51

I have the same problem. Can't get to update list of modules and core. Tried CC, cache_update truncate. Well everything I could come up with and still nothing. What is strange is that on localhost is where I get this, on remote server it is ok.

So I fixed it somehow with disabling and uninstaling update manager and installing it again.

  • Same problem, none of the solutions that I found online worked, except for this one :) Commented Feb 24, 2015 at 15:40

In addition to all the great answers above, be sure to do a double check for possible [facepalm] brain-fail issues:

  • are you logged in to the right server?
  • the right drupal site path on that server?
  • did you mess with your /etc/hosts file and forget?
  • is www and non-www pointed to the same place?
  • are you looking at a local or dev copy in your browser?

If you run drush status and it has the updated version but you still see the update alerts in the GUI Reports > Available Updates page then you might be a total f#¢&ing idiot like me and be looking at different copies of the site.

If you've already tried drush rf and you compare drush status and it has the same current version number you get when you run drush pm-releases drupal then you definitely have an issue other than drush not working properly.

  • Haha this was just me!
    – Chris
    Commented Oct 29, 2018 at 9:06

I also had the same problem.

Restarting MySQL server didn't work for me.

Disabling update manager, uninstalling it and then re-enabling it worked for me.

$ drush -y dis update
$ drush -y pm-uninstall update
$ drush -y en update
  • Didnt I just said that above?
    – Blissful
    Commented Mar 3, 2015 at 14:36
  • Yes, you did. Tried everybody's solution. Just wanted to let others know what worked for me. Luckily your solution worked for me. Commented Mar 4, 2015 at 15:43
  • 1
    @pachabhaiya's commands worked verbatim for me, when restarting MySQL didn't solve it, after running into this exact same issue. Commented Mar 1, 2016 at 17:11

The solution offered by Danny Englander worked.

Restarting mysql server did the trick.

Thanks Danny.


First of all execute:

drush pm-releases drupal

Then you should see all tag names like this:

 Project  Release  Date         Status                                      
  drupal   7.38     2015-Jun-17  Supported, Recommended, Security, Installed 
  drupal   7.x-dev  2015-Jun-17  Development

Now you can get Project name and Release number like this 'drupal-7.38' and execute this to force update to that release:

drush dl drupal-7.38

You can even choose a development version of update by write the development release number.

This also work with update modules. If you need to force update for a module like ctools for a dev release you can execute:

drush dl ctools-7.x-1.x-dev

Enjoy drush <3


I had the same problem, the command

drush up drupal

was not finding the new drupal version. Even the update module, from the admin interface, was not showing the new drupal core release. I've managed truncating the cache_update table

TRUNCATE TABLE  cache_update

For what I've seen, the update module caches the new release informations in this table, for some strange reasons the drush cc all command was not cleaning this table so the new drupal core release colund't be found.


All the answers here and no one suggested the simplest one which works every time for me:

drush cc drush

drush cc all clears all the Drupal caches, but does not clear the drush cache.


It is an old question, but I will share my recent experience regardless. For me, it was just a silly problem with drush not being able to access the internet (as I am behind a proxy).

The solution was to set HTTP_PROXY and HTTPS_PROXY (and their lower-case versions) env variables to the proper values.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.