0

I am connecting to two sites via SSH

I used Drush 4.4 export on a D6 site to export a node type.

I now want to import that onto a D7 site (running Commerce Kickstart2) which contains a newer version of Drush (if that matters) and I get the above error.

I have no alias or rc file on either the old or new site. However I haven't really needed them as all other commands seem to work. I run Status on the new site and it seems to work:

Drupal version         :  7.28                       
 Site URI               :  http://default             
 Database driver        :  mysql                      
 Database username      :  test_commerc           
 Database name          :  test_commerce          
 Default theme          :  garland                    
 Administration theme   :  garland                    
 PHP configuration      :  /home/test_site/php.ini     
 PHP OS                 :  Linux                      
 Drush version          :  6.0-dev                    
 Drush configuration    :                             
 Drush alias files      :                             
 Drupal root            :  /home/test_site1/public_html 
 Site path              :  sites/default              
 File directory path    :  sites/default/files   

The errors are:

The drush command 'import' could not be found.  Run `drush cache-clear drush` to clear the commandfile cache if you have installed new extensions.                    [error]
Drush was not able to start (bootstrap) the Drupal database.                                                                                                          [error]
Hint: This may occur when Drush is trying to:
 * bootstrap a site that has not been installed or does not have a configured database. In this case you can select another site with a working database setup by
specifying the URI to use with the --uri parameter on the command line. See `drush topic docs-aliases` for details.
 * connect the database through a socket. The socket file may be wrong or the php-cli may have no access to it in a jailed shell. See http://drupal.org/node/1428638
for details.

I did run drush cache-clear drush.

I am using a jailshell but this doesn't make sense to me because I can use SQL-CLI for various queries.

What am I missing?

TIA,

  • Have you tried things listed in Hint:? If so, to what effect? If not, why you ask without trying? – Mołot Oct 21 '14 at 19:52
  • 1. Yes, I ran cache-clear drush. 2. Since I -can- connect to the db with drush sql-cli I assume that means that drush can see the configured db. 3. As I wrote I am using a jailed shell, but since I can use drush sql-cli does this apply? – jchwebdev Oct 21 '14 at 20:06
  • Don't use node export to migrate content from an older version of Drupal to a newer version of Drupal; use the migrate module. – greg_1_anderson Oct 21 '14 at 21:26
  • Why? These are just static pages. Not transactions. In any case, unfortunately, we're using Commerce Kickstart2 and migrate seems broken. I don't wanna get into a kerfuffle because the details would take this too far off topic. I just wanna find out what is blocking drush import from working here. Thanks! – jchwebdev Oct 21 '14 at 21:46

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.