1

I have a site running Domain Access with two domains - the primary domain and the sub-domain. Both domains share the same content in the database, but I would like the automated URL aliases for the sub-domain to be different from that of the primary domain's.

There are two tables in the database right now - the url_alias table and the domain_2_url_alias table (of which the latter is a copy of the original url_alias table).

I tried modifying the settings under /admin/build/path/pathauto and selected the sub-domain under the "Save settings for:" option, but that didn't seem to have any effect at all.

I can change the values in domain_2_url_alias manually for each node (which worked), but the site generates new content very often, that this wouldn't be a viable solution.

I appreciate any help I can get! Thanks in advance.

6

I believe this is exactly what the Domain Path module is for.

According to the module page:

The Domain Path module allows the creation of separate path aliases per domain for nodes created using the Domain Access module.

However, it looks like this module provides the option per node, rather than offering different pathauto patterns which I think is what you want. There's a postponed request in the issue queue for pathauto integration that offers a partial patch, but it's offered as an anti-proof-of-concept, it seems.

  • Excerpt or quote from module's page would be appropriate. – Mołot Oct 22 '14 at 19:17
  • I've checked out that module, and it doesn't seem to have any sort of documentation---at least not from what I found. Does anyone know of any documentation on how to configure Domain Path? – edwardchiapet Oct 22 '14 at 20:28
  • Thanks for the response, Kelley! I also found the same patch, but was not sure if there was another patch or module already out there - since there wasn't any confirmation in that thread as to if it worked or not. I'll keep looking and if I come up with an alternate solution, I'll post it here. – edwardchiapet Oct 23 '14 at 15:37
  • Thanks Molot. I updated my response accordingly (but didn't have enough rep to leave a comment until now!) – Kelley Curry Oct 30 '14 at 16:34

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.