1

I was developing on my local machine (Mac OS X) and moved to a VPS with CentOS 6.5. Problem I'm having is with clean urls. It was working fine on the local machine. However on the vps server, I'm seeing something strange. When I go to enable it, I can go to the config page with clean url (example.com/admin/config/search/clean-urls) and the checkbox is enabled. When I check it and save it, the page refreshes with "The configuration option have been saved." but the checkbox is not checked. I can repeat this process. If I look into variables table, I see the following.

+-----------+-------+
| name      | value |
+-----------+-------+
| clean_url | i:1;  |
+-----------+-------+

I cleared cache manually (via MySQL) and through Drupal interface. I checked reports and it is all clean. I looked at logs, but they don't seem to show anything related to this issue. The effect of this is that all URLs generated are ?q=..

Any ideas on what I should look for next?

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.