3

I've been wrestling with this since yesterday and have reinstalled drush 3 times, rebooted, restarted mysql(mariaDB) and a few other things but nothing works. I'm trying to update my core from 7.14 to 7.32 and really want to do it with drush instead of manually. The only thing I think might be causing this is that I am on Debian and my sites directory is a symlink from /usr/share/drupal/sites to /etc/drupal/7/sites or that I have drush installed for root only(composer and drush files in /root)

When I try and update the core with:

drush up drupal

I get back:

Update information last refreshed: Fri, 10/24/2014 - 15:01

Name Installed Version Proposed version Message

drupal Unknown Unknown Specified project not found

No code updates available.

Tried clearing my drush cache to no avail and when I check for releases with drush rl it manages to successfully lists the 7.32:

Project Release Date Status

drupal 7.x-dev 2014-Oct-19 Development

drupal 7.32 2014-Oct-15 Supported, Recommended, Security

I maintain a few Drupal sites with drush and have never had this problem before but this is my only server with Debian so maybe that has something to do with it. I've read a lot of the threads about issues resembling this going back all the way to 2011 but nothing seems to fix my issue.

If anyone can help then thanks and if not I guess I'll have to manually upgrade the core.

2

Try drush pm-refresh, and then run drush pm-updatecode again.

  • Thanks but unfortunately it didn't work... – olssy Oct 24 '14 at 22:09
  • Did you try running pm-updatecode using /etc/drupal/7/sites as your root (via either --root option, or in your site alias)? – greg_1_anderson Oct 25 '14 at 0:24
  • Didn't work either, I get the error: Command pm-update needs a higher bootstrap level to run I also tried using /usr/share/drupal7/sites but it gives the same error. I think I'll try and figure out how the project list is generated to figure out why drupal isn't listed. – olssy Oct 25 '14 at 13:39
  • You need to solve the bootstrap problem before you try to dig into how the code works. Insure that you are passing both --root and --uri, and check to see that drush status reports Database : Connected and Drupal bootstrap : Successful. I would recommend using the path to the actual root, not the symlink path. – greg_1_anderson Oct 25 '14 at 15:19
  • Bootstrap causes no problem when my root is set to /usr/share/drupal7, only when the root is /etc/drupal/7/sites (the core is actually in /usr/share/drupal and that directory has a symlink pointing to the sites directory). With the status command I see that my URI is set to default but even when explicitly specifying it with --uri it doesn't fix anything. I have noticed that the drupal core is absent from the Available Updates page in Drupal whereas it is present on my other sites so I'm wondering if the problem doesn't have to do with Drupal now... – olssy Oct 25 '14 at 17:26
2

Thanks for all your help greg, turns out that 7.14 provided by Debian has this little line in modules/update/update.compare.inc:

// *** Debian specific check *** Debian provides Drupal core updates, no need to check upstream

unset($projects['drupal']);

Commenting out that line fixes updating core with drush. Debian actually provides Drupal 7.14-2+deb7u7 but the only mention of that is here: https://packages.debian.org/wheezy/drupal7

  • Wow, I hope Debian isn't doing that any more; looks like a really bad idea. – greg_1_anderson Oct 28 '14 at 17:21
  • I'm seeing this in an Ubuntu package as well, Debian comment and all. I know these distribtions are related, I just wanted to get the word Ubuntu on the page here. – calebtr Dec 3 '14 at 0:27

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.