1

I have a site with some languages, with language prefix enabled. I wanted the homepage url will be with trailing slash (i.e /en/), so i installed the trailing slash module.

I also want that users who entered my site without language prefix will redirect to the url with the prefix (i.e www.mysite.com -> www.mysite.com/en/), so i istalled th global redirect module, which works well without the trailing slash module.

When the two modules enabled, the redirection in the home page not working. Does someone has solution for this?

0

if you are looking to redirect your users site or visitors to the right language you can do this without global redirect module to do that

  1. install [Localization update][1] , [variable][2] , [Internationalization],
  2. after install modules active Locale , Localization update , Internationalization , Variable
  3. go to Configuration > Languages > detection and selection
  4. the 1st option URL u can choose between (Path prefix or domain) the 2nd option is Browser and here u can Determine the language from the browser's language settings. if your browser's visitor is English he will go to English site .... the 3rd option is User in this option the site Follow the user's language preference.

that's all

  • is there an option that the default prefix will be with trailing slash: www.mysite.com/en/ instead of www.mysite.com/en ? – Liorbd Oct 27 '14 at 7:45
  • i hope that i understand ur question from Configuration > Regional and language > Languages > here u can see your installed languages and u can press edit and choose your Path prefix language code your site will be like this example.com/en – M.Spirit Oct 27 '14 at 9:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.