1

I have a block for a view that i'd like to display on a certain page, but BELOW that page's content. I have the specific page thing working fine, but no matter how many times I rearrange the block for the view to be above or below the "main page content" it does not seem to work! I have tried manually setting page weights in asc and desc order, as well as dragging it above and below. I'm saving often, flushing all caches, and generally grabbing at straws /-:

One hunch: the page it's displaying on is a page showing a custom content type... maybe because of that, "main content" (the only other thing in my "content" region) is not the right thing to order it wrt?

So I've tried already everything in How can i add a block below the content of a node? which is the same as the stuff on Add Block to Content but set it to appear after the node content?

  • Just to check. (1) Are you browsing the page as the administrator (to bypass any possible restriction)? (2) Is it the same after clearing the cache? (3) Can you see the contents in the preview (the bottom part of the editing screen of your Views)? – Masa Sakano Nov 3 '14 at 18:08
  • Check the weight of that content type. Maybe, the weight of that content type is higher. – Vidushi Nov 3 '14 at 18:31
  • assuming everything Masa Sakano checks out, try switching themes... in case the theme you're using is overriding or interfering in the order of blocks – Geoff Nov 4 '14 at 0:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.