1

I've started to use Drupal recently, and installed the jQuery Mobile module and the jQM Theme in order to make a Mobile site / Web app.

I'm having some troubles getting it to work properly.

The thing is, that when I go to my sites front page, I get this view:

screenshot

However, if I click on, let's say 'Store Locator', I get this view:

screenshot

So my problem is, that it seems like the jQuery Mobile stuff (js or css) does not load correctly on the front page.

If I inspect the page, it seems to be the right template, but somehow the js og css isn't loaded correctly.

Has anyone had the same problem?

1
  • in which browser have you tested it? (e.g. in which browser have you made the screenshots above?)
    – Sk8erPeter
    Commented Nov 10, 2011 at 2:19

1 Answer 1

1

Are you including the CSS/JS via your themes .info file? If so, the CSS/JS should be included in the order specified there. The only other thing you should check is that if you have a page override for the homepage (page-front.tpl.php) and verify you have the correct JS/CSS in place in there as well. Good luck

1
  • Hmm.. I quite new to all this, so I have to get my head around all the .info .module files and structures.. But the funny thing is, that the frontpage somehow loads some of the styling, cuz if I disables styles, it looks completely different.. So it's kinda weird..
    – dgsunesen
    Commented Oct 20, 2011 at 8:19

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.