0

All the sudden my site (drupal 7) shows rare characters like �0�1�0�

Also, the links doesn't work. All links in the site reload the home page. I can't access example.com/user neither.

Please help. The site was working fine yesterday and did not make any change.

The encoding of the page is: UTF-8

Meta Content-Type is text/html; charset=utf-8

I can use Drush in the site. I already run drush cc all and drush cron and drush updatedb. But problem is not fixed.

Please help.

  • 1
    Inspect immediately your site as it may have been infected. This sounds as if something has been injected to pages and breaks the display in your browser. See this for more information. – Aram Boyajyan Nov 5 '14 at 11:17
  • There's a very strong possibility your site has been compromised. You'll need to check properly (see the duplicate), but if after a thorough investigation it turns our you haven't been compromised, and the problem persists, please edit the question and provide some more details from your debugging efforts. There isn't enough information for anyone to give a reasonable answer at the moment, even if your site hasn't been hacked – Clive Nov 5 '14 at 11:35
  • @Topsitemakers if this is the case, restoring the database will fix the problem. Are the files infected as well? – chefnelone Nov 5 '14 at 11:40
  • 1
    You'll need to check @chefnelone, no way to tell from here. It's possible that your files and/or server have been compromised, depending on how you have hosting set up – Clive Nov 5 '14 at 11:41
  • I get back the site using a old backup and then replacing sites/default/files and using the actual database. No problem so far. But I'll check if the site is compromised in any way. – chefnelone Nov 6 '14 at 20:10

Browse other questions tagged or ask your own question.