1

I Have Entity Module and already have a Taxonomy Vocabulary with terms and an Image Field created. Each term has a unique image.

I Have a Content Type with a Term Reference field set to allow multiple selections of my Vocabulary.

I now want to have my Nodes displayed in a Views Table, Title, Node Image, and Taxonomy terms as images rather than their names.

How do I make this possible? Here is a link to what the site currently is (HTML Table rather than a view - very limiting and slow for updating). http://dev.destinationsound.net/

The different color circles are what will be taxonomy terms.

Drupal 7

Note: This is not for a taxonomy term page but rather a list of nodes that have taxonomy terms associated with them.

1
  1. Create a view of the appropriate nodes
  2. Set the view output type to be "table"
  3. Create a "relationship" in the view between node and taxonomy term
  4. Now you can add the image field from the term to your views output
  5. If you use multiple vocabularies, add a filter to select just the vocabulary you are interested in.

If you don't already have the imagecache module installed, I recommend it as it will let you control the size of the displayed image.

  • Thanks. I tried adding a relationship and what it did, since one node has multiple terms, it displays the node multiple times, once for each term it has. I chose "Content: Taxonomy terms on node", selected required and selected the vocabulary I want associated. – Anon Ymous Nov 7 '14 at 0:37
  • Its not an issue of multiple vocabularies, rather multiple terms within my vocabulary. Each Node has up to 6 terms that can be simultaniously selected. This is resulting in repeated entries of the same node, one for each node. In my example I have 2 test nodes. The view outputs 3 of each node (6 total) because each node has 3 terms selected. I want one listing for each node but with their multiple terms showing. – Anon Ymous Nov 7 '14 at 0:52
  • You can solve this in 1 of two ways: - Select the "unique" setting in the view - Enable the "aggregation" feature – Coleman Nov 7 '14 at 0:53
  • Better answer: You can solve this by enabling the "aggregation" feature, and then choose an aggregation method for your taxonomy field, e.g. "group results together". – Coleman Nov 7 '14 at 0:59
  • Almost there. It now only shows 2 nodes, but now only one of the term images is showing. There should be all three – Anon Ymous Nov 7 '14 at 1:15

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.