0

Is there anywhere in the administrators area can I set $vars['view']->date_info->granularity ?

With the recent updates to Drupal 7.32 the date format of the calendar module heading has changed from [month][year] to [day],[month][day number],[year] which looks silly.

I assume granularity has changed from 'month' to 'day', but I can't find where to change it back.

Is this associated with the fixed bug number 355058?

1 Answer 1

0

Here is the quick workaround for the issue:

STEP 1: Edit modules/date/date_views/theme/theme.inc and go find line 165.

Change these two lines:

$format_with_year = variable_get('date_views_' . $granularity . 'format_with_year', 'l, F j, Y');
$format_without_year = variable_get('date_views_' . $granularity . 'format_without_year', 'l, F j');

To these two lines:

$format_with_year = variable_get('date_views_' . $granularity . '_format_with_year', 'l, F j, Y');
$format_without_year = variable_get('date_views_' . $granularity . '_format_without_year', 'l, F j');

Note: the only difference is one underscore character added to each line.

Upload the changed file back to your web server.

STEP 2: Go to (YOUR_WEBSITE)/admin/config/regional/date-time/date-views and click Save. If you get permissions errors, try clearing caches.

Before:

enter image description here

After:

enter image description here

1
  • Also need to manually apply patch in drupal.org/node/2313587 to enable permissions on (YOUR_WEBSITE)/admin/config/regional/date-time/date-views Nov 9, 2014 at 17:02

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.