2

I am having some issues on installing Open Public distribution (openpublic 7.x-1.2) on IIS 8.0 and SQL Server 2012 R2 without Web PI. Have any one tried it before in such way ? Is it possible ? I can install "standard" distribution on IIS 8.0 and SQL Server 2012 R2 without Web PI, without any major issue.

This is the issue I am experiencing during installation of Open Public distribution:

An AJAX HTTP error occurred. HTTP Result Code: 200 Debugging information follows. 
Path: http://endri.net/install.php?profile=openpublic&locale=en&id=1&op=do 
StatusText: OK 
ResponseText: Home | Drupal @import url("http://endri.net/modules/system/system.theme.css?0"); .... Home Installation tasksChoose profile(done)Choose language(done)Verify requirements(done)Set up database(done)Install profile(active)Configure siteVerify Apps supportInstall AppsFinished Status message You can now configure the CAPTCHA module for your site. SQLSTATE[42000]: [Microsoft][SQL Server Native Client 11.0][SQL Server]Procedure or function dbo.CONCAT has too many arguments specified. 

and

Warning: file_put_contents(temporary:///.htaccess): failed to open stream: "DrupalTemporaryStreamWrapper::stream_open" call failed in file_create_htaccess() (line 494 of C:\inetpub\wwwroot\includes\file.inc).
1

I have solved, the issue is at this file on this location:

C:\inetpub\wwwroot\profiles\openpublic\modules\contrib\comment_notify\comment_notify.install

the statement on line 24

$comments_select->addExpression("MD5(CONCAT(:salt,c.mail,COALESCE(u.mail, u.init), c.uid,c.name,c.nid,c.hostname, c.cid))", 'notify_hash', array(':salt' => $salt));

should be replaced with

$comments_select->addExpression("MD5(CONCAT(CONCAT( CONCAT(:salt, c.mail) , CONCAT(COALESCE(u.mail, u.init), c.uid) ),CONCAT( CONCAT(c.name, c.nid) , CONCAT(c.hostname, c.cid) )))", 'notify_hash', array(':salt' => $salt));

because "Drupal 7 driver for SQL Server and SQL Azure" drops the SQL Server stored procedure CONCAT and creates a new one with only 2 parameters.

0

The specific error seems to be a permissions problem that prevents writing the .htaccess file, probably in your DOCROOT.

The more general problem is that anything is being done with an .htaccess file on an IIS server. See http://www.iis.net/learn/application-frameworks/install-and-configure-php-applications-on-iis/translate-htaccess-content-to-iis-webconfig for why that should not need to be attempted in your installation.

I expect either that Open Public does not support IIS (most likely) or you have failed to provide an installation parameter specifying IIS rather than Apache as the webserver.

  • The access problem seemed to be unrelated to the main issue, i have solved it. See my answer below. – endri Nov 10 '14 at 9:31

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.