6

How do I display an entire node content and not just some intro text on the front page? It seems anything I promote to front page, is also truncated and I can't figure out how to turn this off.

14

The easiest way is to create a view.

Follow these steps:

  • Download, extract the Views module
  • Enable the Views UI module and accept enable the modules that provide the dependencies
  • Go to the views admin page (admin/structure/views)
  • Enable the frontpage view (click the link)
  • Edit the frontpage view (click the link)
  • Under the format heading, there is an option "show" click the teaser link
  • Change the view mode option to full and untick the show links checkbox
  • Click the Apply (all displays) button
  • Click the save button
  • Visit the site information page (admin/config/system/site-information)
  • Change the default front page URL to "frontpage" (without the quotes)
  • Click Save configuration

It show now just work.

11

Enter your site configuration to set Default front page and set the node path (node/[id]) as path to default front page.

5

Consider Using Panels and Views (as pcambra suggest). Here are some tutorials:

With Panels and Views your limitation is only your imagination

  • Despite not exactly answering the question, this is the best answer in my opinion. Up-voted. – Letharion Jan 3 '12 at 14:26
2

One solution would be to turn on the "Emulate Frontpage" View in views.module and modify it to show the full node, not only the teaser.

1

the front module might work for you too. There is an "alias" option that you could use to show a certain node page as the front page.

1

Depends on the complexity you want, but probably the Default front page solution proposed by Shoaib is the simplest one.

You could also use panels for this if you're already using it if you're not, it's not worthy to install it just for the frontpage, same thing happens with the Views solution.

0

From the admin menu go to Structure > Content Types. From the list select Article and then click Manage Displays. Now at the top you will see 2 items Default and Teaser. Select "Teaser" and change the Body Format from Summary or Trimmed to Default

0

Bas G's solution is good, but if your front page is a "page" and not an article, you have to change to default under

/admin/structure/types/manage/page/display/teaser

but then there still is a "read more" link on the bottom of the front page content, even if you see the whole content. I managed it it by going to

/admin/config/system/site-information

and setting there the direct link to the frontpage node under Default front page, like this

http://www.example.com/content/<node_title>

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.