1

I added a date to the user profile form under admin/config/people/accounts/fields. The field is of type 'date', the widget of type 'select list' and I only collect year, month and day.

Without altering anything the date entry widget is shown on the form in the order year-month-day.

Since the order in the Netherlands should be day-month-year, I set out to change the date format by:

  • Adding a new custom format d/m/Y under admin/config/regional/date-time/formats
  • Create a new date type called 'test' and referencing the custom format from the previous step under admin/config/regional/date-time
  • Changed the date display format to the 'test' type, under admin/config/people/accounts/display - press update and save the settings

In the date preview of admin/config/people/accounts/display, the date is shown as DD-MM-YYYY which is the format I want.

Now, going to the user profile page under user//edit, the date order shown as month-day-year.

I have tested this on a clean installation of Drupal 7.33 and the only module added is the date module 7.x-2.8.

How can I change the display order for this specific field?

Kind regards, Eric van der Staaij

0

Date entry format is configurable, what you did was changing the way the date will display on content but not on create content form. To change it go to your field configuration page on content type then find more settings and values collapsed fieldset and inside it look for date entry options and change to whatever.

https://docs.google.com/a/srijan.in/file/d/0B9FG53CLjf-YdEFfdzVEV1hmcWc/edit?usp=drivesdk

  • Ah. Thanks. I now found it. It was a collapsed fieldset indeed and I totally looked over it. Thanks! – Vanderstaaij Nov 18 '14 at 15:45
-1

Please refer the Community Documentation of Usage example of date elements within forms in the Date API form elements for the solution.

Thank you.

  • That is for programmatticaly adding or modifying forms. Not when using Drupal's user interface to manage and display fields. – Vanderstaaij Nov 17 '14 at 12:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.