0

I have two content types.

  • Images
  • Question

The question content type is meant to allow users to ask questions about the photos in the images content type.

I added a node reference field with "reference from url" type selected to the question content type. I checked "create link on the full view" during the setup. This works correctly if I go to an "images" node.

However, I am displaying the "image" type in a view. So far I can not figure out how to get a link to the question content type to show on the view. I have tried this using a "references" display type of the view, but still nothing.

1

Set up the relationship:

  • Under the Relationships section in advance settings. click + to add a relationship.
  • Under "Add relationships" you will see all fields listed.
  • Drop down the Groups menu and select "Content".
  • Locate your node reference field, for example 'Content: Reference question (field_reference_question)'. Check the box to the left of it.
  • Click the Add button.
  • Check the box labeled 'Require this relationship', and click the Update button.

Add a field:

  • Click + next to Fields. Under Groups, select Node, and choose Node: Title. Under Relationship, select your node reference field, e.g., Reference question, click Update.
0

In your view you need to add your question type in the References in Advanced Settings.

Then as you add your field to the view you create, in the Relationship drop down, chose your relationship name (the default is Do not use relationship)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.