I am running on Windows 7 Enterprise and have done to following to set up my site:

  1. Downloaded and installed Virtual Box VirtualBox-4.3.18-96516-Win.exe
  2. Downloaded and installed vagrant_1.6.5.msi
  3. Downloaded vdd-8.x-1.0-alpha4.zip
  4. Extracted the zip file and copied the vdd folder to /Test so I have /Test/vdd as my vdd directory
  5. opened a command prompt and went to /Test/vdd
  6. Ran vagrant up and it seemed to work.
  7. Accessed the vm by using vagrant ssh
  8. Changed permission on all directories to 777 (i.e. chmod -R 777 sites and I verified that all directories are 777)
  9. The drupal7 directory did not have a setting.php file. I copied default.setting.php from default directory to the drupal7 directory and named it settings.php.
  10. Also copied settings.php to default directory so default has both settings.php and default.settings.php

Now when I run drush @drupal7 site-install -y I get the following:

Command site-install needs a higher bootstrap level to run - you will need to invoke drush from a more functional Drupal environment to run this command. The drush command 'site-install' could not be executed. The directory /var/www/drupal8 does not contain a valid Drupal installation

A couple of things worthy to note is that my drupal7 directory has no files other than settings.php.
I don't know if that is the way it is supposed to be.
mysql is up and running. If I run mysql -u root -proot it connects to the db.
I am assuming apache and php are working because returns the proper landing page.

1 Answer 1


The Documentation shows the steps you should do are:

  1. Start with empty directory and prepared empty database (or user with permission to create database)
  2. drush dl drupal --drupal-project-rename=example
  3. cd example
  4. drush site-install standard --db-url='mysql://[db_user]:[db_pass]@localhost/[db_name]' --site-name=Example

You should not manually create, copy, move config files before executing drush site-install. And you should not use aliases like @drupal7 unless they are defined. In case of installation, I always set up site first, and aliass for it later, and it worked all right.

  • "dl has been removed" ... this answer is outdated now, right? I'm having the same problem. Can't install Drupal 7 with drush site-install because it won't recognize that Drupal is there. Documentation wants me to use composer_generate, which wants me to install it with drush dl, which doesn't work anymore, and needs an already-installed drupal anyway. I can't find an example of what composer.json should look like for Drupal 7, and there is none included in the download. Jan 15, 2020 at 17:50
  • @RaisinBranCrunch this answer is six years old, under a question that earned enough importance and interest to be at only one upvote after all this time. Of course it is outdated. Anything not interesting to no one won't be updated. "answer is outdated" is one of the bounty reasons, if you want to attract someone who can write one more relevant to the content state of things.
    – Mołot
    Jan 15, 2020 at 20:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.