0

I am a site admin (Drupal 7 - all updates are current) and am able to log in with my own credentials. I'm working an issue and need to log in as another non-admin user. No matter what I try, I'm not able to log in as this particular other user though I have verified their user email address and password. I have copied and pasted their email address directly from their user account. I have also reset their password so I know it is correct. I have tried turning off clean url's (as suggested by another forum), but that didn't help. I have cleared the site cache. I contacted the user and she is able to log in/out and back in with the exact same credentials I'm attempting to use. We have had this problem with another non-admin user on this particular site but it hasn't happened in quite a while and never with this user. I have logged in as this user prior to this happening but it has been a few months.

I saw another post on this site about the same thing but didn't really see a solution (Cannot log in to Drupal site).

Does anyone have any ideas? This is quite an inconvenience.

  • is the user active maybe it was blocked? – cayerdis Nov 22 '14 at 1:03
  • Thank you for your input, cayerdis, but user is active. In short, there is no apparent or logical reason this should be happening. I will be happy to eat those words if someone can find an apparent or logical reason:) – Lu R Nov 22 '14 at 1:08
  • Did you try clearing the browsers cookies ? – Parag Nov 22 '14 at 4:06
  • What actually happens when you try to log in? Does it seem like it logs in but then doesn't or do you get an invalid username or passeord error, or something else? Have you checked the contents of the "flood" database table? – rooby Nov 22 '14 at 6:44
  • Have you tried using the 'Masquerade' module: drupal.org/project/masquerade – 2pha Nov 22 '14 at 6:44
0

Once I was able to get in touch with my other site admin and she was able to log in with the same credentials I knew the problem was local. I had tried different browsers. I flushed my DNS and rebooted my computer and was able to log in.

-1

I have got a similar issue because other users of your Drupal 7 site will have same permissions as the administrator is assigned with.

See the values stored in role and role_permission tables in your Drupal database.

Check if the rid value is assigned with similar permission values in the role_permission table.[Also take care of the module field if many exist]

If so, this would be because of the reason that the users' roles are created with extra permissions other than:

access content
post comments
skip comment approval
use text format

-which are the default permissions assigned to the authenticated user.

All you can do now is either manually edit the table values[not suggested by the community] or use a module to update the user permissions for each roles.

Thank you.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.