0

In my product display content type, I created a new image field and am aiming to show that in a view among other things. I after long research found out that I have to enable indexing of a field before I can use it in a view. However, this new field is nowhere to be found on Search API settings. Where else can I look?

Best, mto

0

Do you have "Search Index " display settings enabled (#overlay=admin/structure/types/manage/product_display/display) If so, then I guess you may have to enable this field in the Manage display of Search Index display.

0

If you go to admin/config/search/search_api, then I guess you could see a server of type "Index". Click on the Edit link against that and go to the "fields" tab(admin/config/search/search_api/index/product_display/fields). Enable the checkbox against your new field and save. You will have to index the whole content, which you can do by click the view tab and clicking the "Index Now" button. I guess this would do.

1
  • You are right I can do that, but I can't see the field there. – Kartagis Nov 25 '14 at 7:17
0

In case others are looking for the answer, check out hook_entity_property_info Clear cache and then your entity fields should appear.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.