0

I have made a subtheme out of the Omega 4 with the responsive structure. I tried to use exposed sort for views inside the layouts of the subtheme.

The exposed sorts are not working under the activation of AJAX inside the views, but the exposed filters are working.

Any recommendations?!

1
  • I need to use them with AJAX! but the exposed sorts are not really working!
    – Ehsan
    Commented Nov 25, 2014 at 16:42

3 Answers 3

1

I found the solution, it seems to be a database problem for Drupal, and nothing to do with Theme or Views!


Just remove that specific view from the layout inside your Panel/Page design in Pages section, and add it another time.


It will update the Drupal database and everything starts to work!

0
  • This Issue may come from Omega's responsive grid Try Deactivating it.

  • Check this Link which replicates your question

3
  • Thank you for your reply. I have actually read it previously and the only issue is that I have to keep the responsive design as its a requirement for the current project I'm doing. I was only looking for other ideas inside here, as I explored the ideas in drupal.org
    – Ehsan
    Commented Nov 25, 2014 at 18:12
  • I found the solution and have updated both my post and Drupal.org post.
    – Ehsan
    Commented Nov 26, 2014 at 8:44
  • That's cool !!! Commented Nov 26, 2014 at 8:48
0

Replace your Views theme file with the original, that you get from Views.

For me; copying views-view.tpl, to my custom theme (e.g. views-view--locations--contact-us.tpl) helped to solve the issue.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.