1

I am trying to update Drupal core from 7.32 to 7.34 using drush. It initially appears to be sucessful, however the status report and /modules/system/system.info still show the version number as 7.32. I have tried running update.php but it says that there are no updates.

I have another Drupal site on the same server that is very similar and had no issues updating it to 7.34.

The output of drush when updating is:

drush5.5-sp pm-update
 Name    Installed Version  Proposed version  Message
 Drupal  7.32               7.34              SECURITY UPDATE available


Update information last refreshed: Thu, 11/27/2014 - 22:43
Code updates will be made to drupal core.
WARNING:  Updating core will discard any modifications made to Drupal core files, most noteworthy among these are .htaccess and robots.txt.  If you have made any modifications to these files, please back them up before updating so that you can re-create your modifications in the updated version of the file.
Note: Updating core can potentially break your site. It is NOT recommended to update production sites without prior testing.

Do you really want to continue? (y/n): y
Project drupal was updated successfully. Installed version is now 7.34.
Backups were saved into the directory                                [ok]
/srv/users/site/drush-backups/u7i6t765rib76nb7tionytbyi_site/20141127154450/drupal.
No database updates required                                         [success]
'all' cache was cleared.                                             [success]
Finished performing updates.                                         [ok]
  • If you run: drush pm-refresh and then: drush status in this particular directory what do you see? Does it tell you that the directory has 7.32 or 7.34? If it says 7.34, then I would navigate to /modules/system and vi system.info to see what version it shows. Perhaps, you're not in the correct directory for the site you're trying to update? – Andrew Wasson Nov 27 '14 at 18:36
  • Check file permissions? Sounds like a bug in Drush -- something is causing the update to fail, but Drush does not catch it and reports success. – greg_1_anderson Nov 27 '14 at 20:55
  • It still shows 7.32 with drush status and the permissions appear to be the same as the other site that worked. I'm going to try to download the update and replace the files manually to see if I have any better luck that way. – zen_mind Dec 3 '14 at 10:05
  • I'd be curious what a "hacked" report says about your installation. – Screenack Sep 20 '15 at 17:30
0

You don't need the drush. download the latest version, remove the /sites folder from the downloaded files and then simply copy and replace the files with the existing ones.

  • 1
    The OP is wondering why the update worked with a site and not the other. They aren't asking for alternative ways of updating Drupal. – kiamlaluno Nov 27 '14 at 17:51

Not the answer you're looking for? Browse other questions tagged or ask your own question.