1

In Drupal 7, I am trying to upload an image that belongs to a custom type.

I click the Browse button, choose the file and upload. Until there, all seems to work well.

uploaded

However, when I click next, instead of the add alt, title and text, I get only a screen that says Destination *, and with a Previous and Next buttons, as shown below. The save button is never displayed, and the image is not shown.

what is this?

However, the image is there if I check the files through the admin, moreover, all goes well If I add the image through the file/add, it is just in the custom type that I get the error.

I am logged in as an administrator and I have all the permissions checked in Media and File Entity

My files folder permissions are 755, and the javascript console shows: 'Attr.nodeValue' is deprecated. Please use 'value' instead. in jquery.js

Resource interpreted as Script but transferred with MIME type text/html: "about:blank" in browser?render=media-popup&types[]=image&activePlugins=&enabledPlugins=&schemes[]=public&schemes[]=…:92 (anonymous function)

Thanks in advance for your help.

Update, this doesn't work with Image widget nor Media Browser widget. Same site works in PROD, I suppose it is something with the file system settings?

0

These fixed it:

-I changed the content type to image instead of media browser.

-Reviewed the permissions for file and this particular content type.

-Changed the field display of the content type

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.