9

I'm using Entity Reference to create tasks in lists - both tasks and lists are content type, list contains multivalue Entity Reference to task. Because most tasks belong to only one list, it was only natural to use Inline Entity Form.

Problem is most - there are some tasks that needs to belong to many lists.

Module's docs says:

Existing entities can also be referenced.

That would do the trick. My question is very simple: How do I do that? Only button I see is "Add new node", and it opens node creation form. What should I do to see "Add existing node"?

  • 1
    +1 I don't know why this was downvoted, I have the same question ;-) – Adrian Cid Almaguer Jan 24 '16 at 0:08
7

To add more clarity to the answer:

  • In Edit tab, check "allow users to select existing nodes" as shown below

enter image description here

  • In your content creation form, you could find two buttons: Add New Node and Add Existing Node as shown below

enter image description here

4

Inline Entity Form settings are in the Edit tab, not the Field settings one. Once I realized this, it was easy to find Allow users to add existing nodes checkbox. Once it's checked, there are two buttons on field's list: a button for creating a new reference, and one for referring the existing nodes.

3

The important yet confusing step I observed when wanting to add an existing term, for example, was to make sure you select "Inline entity form - Multiple values" not single values (see https://www.drupal.org/node/2134035). The current patch needs community review.

  • In what version? Because I don't remember it to be an issue. – Mołot Jun 13 '15 at 8:23
  • AFAIK, this is a long-standing issue (that still hasn't been resolved). See drupal.org/node/2134035 – Vishnar Tadeleratha Jun 19 '15 at 1:05
  • @Molot which version do you have? I test 1.6 and dev and both have the issue – Adrian Cid Almaguer Jan 24 '16 at 3:42
  • @AdrianCidAlmaguer this was long time ago. If you have the same issue, see linked patch file, it looks like a good thing. – Mołot Jan 24 '16 at 7:53

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.