1

I am trying to use omega-wizard but I think I am using the wrong version of Drush. I want to use the drush the is in Acquia Dev Desktop but when i type which drush I get the one that was last installed with MAMP (running OSX).

When trying to run drush omega-wizard I get this message:

The drush command 'omega-wizard' could not be found.  Run `drush cache-clear drush` to clear the commandfile cache if you   [error]
have installed new extensions.
                                                                                                                            [error]
Drush was not able to start (bootstrap) the Drupal database.
Hint: This may occur when Drush is trying to:
 * bootstrap a site that has not been installed or does not have a configured database. In this case you can select another
site with a working database setup by specifying the URI to use with the --uri parameter on the command line. See `drush
topic docs-aliases` for details.
 * connect the database through a socket. The socket file may be wrong or the php-cli may have no access to it in a jailed
shell. See http://drupal.org/node/1428638 for details.

Drush was attempting to connect to: 
 Drupal version         :  7.34                                                         
 Site URI               :  `http://default`                                               
 Default theme          :  garland                                                      
 Administration theme   :  garland                                                      
 PHP executable         :  /Applications/Dev Desktop/php5_5/bin/php                     
 PHP configuration      :  "/Applications/Dev Desktop/php5_5/bin/php.ini"               
 PHP OS                 :  Darwin                                                       
 Drush version          :  6.2.0                                                        
 Drush configuration    :                                                               
 Drush alias files      :                                                               
 Drupal root            :  /Users/khrysztov/Sites/devdesktop/acquia-drupal-7.34.40.6204 
 Site path              :  sites/default                                                
 File directory path    :  sites/default/files

I cannot see any reference to the database there in the parameters and the default theme is not Garland.

Any ideas?

1
  • 1
    Just edit your .bashrc file and add an alias for drush: alias drush='php ~/.composer/vendor/drush/drush/drush.php' (edit to meet your environment).
    – Paul
    Dec 4, 2014 at 7:38

1 Answer 1

0

Answer by Paul worked (thanks):

alias drush='"/Applications/Dev Desktop/drush/drush"'

Needed inner double quotes to allow for space in Dev Desktop.

2
  • Or just use alias drush='/Applications/Dev\ Desktop/drush/drush'.
    – apaderno
    Dec 4, 2014 at 10:43
  • Yeah for some reason the escape character wasn't working. I was just pleased to get it working after spending a long time looking for a solution so I was happy with the double quotes.
    – Khrys
    Dec 5, 2014 at 15:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.