What I have:

  1. Drupal 7.0
  2. PHP 5.2
  3. IIS 6.0
  4. SQL server Enterprise Manager 2003
  5. SQL server 2000 running on local system(my database is on the same system.)
  6. Windows Server 2003.(makes any difference?)

I am using VPN to connect to the production system.(relevant?)

  1. I have added the Microsoft SQL Drivers 2.0 to the php/ext folder.
  2. I have added the sqlsrv module to the database\includes as well.

Got the option to install Drupal to sql server which was the only option by default in this case (got a message that my server does not support multiple databases hence sql server was selected by default).

I have the following fields available to me in the database setup:

The values I have entered are in []:

  1. database type:radio button (selected by default--microsoft SQL server)
  2. database name: [database_name]
  3. database user name: [user_name]
  4. database password: [password]

Advanced options:

  1. hostname: [localhost]
  2. port: blank
  3. prefix: blank

I get an SQLState[20008]:SQL server native client [10.0] error: can't login.

what are the possible reason for not being able to connect?

1 Answer 1


I am not sure why you are using SQL2000 in 2014 because it is not supported anymore. I have successfully connected to SQL 2008 version using SQLSRV module in Drupal.

I would do the following in this case:

  • Make sure TCP\IP protocol is enabled and it is listening on some port which is not getting blocked by firewall.

  • I would try connecting to the database server using IP address and port using enterprise manager first.

  • I would look in my SQL error logs because it records the authentication failures there.

Please share what you observe.

Thanks C

  • i know it is dumb to use SQL 2000 today. But it was for a client. Finally convinced them to use MySQL instead. will post when i get to deal with it again.
    – dresh
    Commented Dec 17, 2014 at 5:10

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.