1

I have a Event content type with a body and date field from the Date module.

I have a view that shows the events as a block in ascending order, and everything looks cool when I view as an admin. All day events are displayed without a time.

Event Foo 12/06/2014 to 12/09/2014

However when I look at the block as an anonymous user all day events show up as starting and ending at 2:00

Event Foo 12/06/2014 - 02:00 to 12/09/2014 - 02:00

How can I get rid of the time?

Edit: How the Date field looks in the node edit form: date field from node

  • You need to show us how you've implemented 'all day' events. – Darvanen Dec 5 '14 at 0:08
  • I have turned on the date_all_day module and enabled the collect end date option. In the node edit forms I've checked the "all day" and "Show End Date" checkboxes in the date field. – Wadelp Dec 5 '14 at 0:17
0

Fixed this issue by creating a custom date format and date type. /admin/config/regional/date-time

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.