I am in process of creating a new website from old Joomla based site. I manage to import with feeds module all the old content. On the localhost server there is no problem but on production server all of the imported images and their derivatives are not showing. The problem links looks something like this


My first suggestion was that this images have problem with the image style 'itok' token

Any suggestion would be deeply appreciated. Thanks.

What I tried so far: First all images were imported with single space after the extension so the link looks like this:


I didn't catch it before uploading finished site on production where all the images disappeared so I thought that this is the problem and after trying some weird things with no avail import again all joomla based content without the space. Second I presume that I have some problem with itok token and flushed all images and regenerated them again.

Now I uploaded the whole site on different hosting where all worked correctly so after conversing directly with the gays from original hosting company it turns out that they are updating their server on the fly during working hours and all my jumbo mumbo with database and files were restored few times on the row.

So I finished with apologies from them and one day spend searching for something that was not there.

  • Are these files even there? If copying them from localhost to peoduction failed and you simply didn't migrate them, we can't help you, Drupal can't use things that simply are not there. And how are these links generated? itok is a security token and simply can't be hardcoded.
    – Mołot
    Commented Dec 5, 2014 at 12:41
  • Yes the files are there. That's the first thing I checked. Links are generated from Views that use image styles. I know that itok is security token generated from Drupal. I am moving the whole site on different hosting so to determine if the problem was not from Drupal but some miss configuration file permission etc.
    – NexusStar
    Commented Dec 5, 2014 at 15:06
  • Please edit what you tried directly into question. What appears in logs?
    – Mołot
    Commented Dec 5, 2014 at 15:14

1 Answer 1


First, make sure your images are actually uploaded to the server and accessible (go to http://SITEURL/sites/PATH/TO/IMAGE/DIR/image/274f1bf2bd18e7f0d33d6244e658426e.jpg to check), then make sure the file and directory permissions are correct. Check the admin/config/media/file-system page, and click "save" – if it's not setup correctly it should display an error message and you'll most likely have to change directory permissions.

Don't worry about the tokens or anything after .jpg (ie: ?itok=AUwo0SYX) –– those are merely for cache-clearing, and can be safely ignored, it has no impact on accessing the images on the server.

  • I am selecting your answer as correct so after all was cleared it was exactly permission problems and files not there :-).
    – NexusStar
    Commented Dec 5, 2014 at 15:33

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.