Commerce Kickstart 2. I noticed that unpublished Products were still visible to users who are not logged in or have editing permissions.

I saw this topic: https://www.drupal.org/node/1899326 which states that one must check the 'Exclude unpublished nodes' box as well as the 'Exclude unpublished products' box in the Filters tab of


...but when I click 'Save' I get the error:

Contained fields field is required

...five times.

What is causing this? How do I correct?

1 Answer 1


I am not sure if you found the solution for this error, but here is what i did.

on the /admin/config/search/search_api/index/product_display/workflow, the aggragated field settings, remove the fields that you don't need or have "unchecked" on the fields tab.

Hope this helps


  • Honestly, it's been so long, I've forgotten. One of the -key- failings of this 'forum' is that there is no way to 'bump' a topic; so if one doesn't get a quick reply, the question just disappears. I see hundreds of orphans here. That said, I -think- I found that there was a patch to SOLR that fixed it through endless Googling. You gotta be a Google-Ninja if you wanna use Commerce.
    – jchwebdev
    Apr 29, 2015 at 20:37

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.