3

I've tried to install a second language to my Drupal7 site. It can be done either by automatically or manually translation. I tried both but I got into the following issue at halftime:

Maximum execution time of 240 seconds exceeded.

I tried to set higher values in php.ini:

default_socket_timeout = 240 (it was 60)
max_input_time = 360;
max_execution_time = 360;

I using local WAMP and Drupal7 installation. Port 8888.

I need help with configuration or another way to install it.

1
  • Temporarily setting max_execution_time = 0; will disable the 240 s limit and let you complete the task. But only in Drupal 7.40 and later, due to issue #2233929.
    – tanius
    Dec 7, 2015 at 3:37

2 Answers 2

3

Open sites/all/modules/l10n_update/l10n_update.locale.inc; at line 28, change the code to the following one:

drupal_set_time_limit(840);

It will increase the execution time and will work. The original code set the time limit to 240.

0

Make sure you restarted your server (apache) to let the changes take effect.

1
  • It seems like the 10n_update.locale.inc setting overwrites the php init setting. Oct 25, 2011 at 6:32

Not the answer you're looking for? Browse other questions tagged or ask your own question.