1

I created the basic page, then added alias front_page. Next, I created a translation of this node and have the same alias. In the settings admin/config/system/site-information in the field Default front page I added front_page, but on the home page is displayed when you switch the language is the same article, without translation. How to fix it?

1

You need to use the Variable Translation for that:

  • In Configuration > Regional and languages: Multilingual settings > Variables, enable 'Default front page' as a multilingual variable.
  • Go to Configuration > System > Site information > Front page.
  • Change the language via the section "Select language" at the top of the page to select the language for which you're setting the front page option.
  • Set the 'Default front page' option for the current language.
  • Repeat as necessary for each available language.

Relevant link: HowTo: Different home page (default front page) for each language

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.