1

Please accept my warm regards . I need some guidance and light to move ahead.

I am from SQL Server background and has been doing some work on Linux machine offlate and making it connect with SQL Server. I have succesfully installed FreeTDS and can connect to Windows SQL Server machine. Now, I installing Drupal in Linux and during its installation it creates multiple tables in the database.

After creating few tables it quits. I traced and found that it stopped because it needed ANSI settings ON to create an index on the table date_formats but found it off. I cannot set it at my DB because it chooses the client settings at the runtime.

I am not sure if Drupal install.php opens a connection with ANSI off settings because this causes the index creation to fail. Please help to investigate it.

Regards Chandan Jha

0

1 Answer 1

0

If you look in database.inc for your database driver you can see what parameters are passed from drupal on the default connection. If you apply this patch to drupal8 you can set additional PDO options supported by the driver https://www.drupal.org/node/1926284

5
  • Thanks for your suggestion. I am a DBA and apologize for my limited understanding of php and commands.This is what I found in the database.inc file of DBLib which is a brother os sqlsrv and used for Linux flavours:
    – Chandan
    Commented Dec 13, 2014 at 13:08
  • // Build the DSN. $options = array( 'host=' . $connection_options['host'] . (!empty($connection_options['port']) ? ',' . $connection_options['port'] : ''), 'dbname=' . $connection_options['database'], ); if (!empty($connection_options['charset'])) { $options[] = 'charset=' . $connection_options['charset']; } // Launch the connection to the server. parent::__construct('dblib:' . implode(';', $options), $connection_options['username'], $connection_options['password'], array(
    – Chandan
    Commented Dec 13, 2014 at 13:14
  • Please let me know what can I append in it to make sure it sets ANSI settings to ON. Also, I tried to put ANSI to ON in FreeTDS.conf as well as odbc.ini but with no luck.
    – Chandan
    Commented Dec 13, 2014 at 13:15
  • hmmm ... try this? drupal.org/project/sqlsrv I found it from this lenghty set of notes: drupal.org/node/2288167#comment-9174981
    – tenken
    Commented Dec 13, 2014 at 23:58
  • My friend, 'sqlsrv' module is meant for Drupal running on windows server and not on Linux. I have already set up Drupal on windows with SQL Server. DBLib module was created by the same guy for Linux but it has hit a roadblock in my case.
    – Chandan
    Commented Dec 15, 2014 at 6:06

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge you have read our privacy policy.

Not the answer you're looking for? Browse other questions tagged or ask your own question.