3

Something's very wierd with my existing Drupal 7 setup (current Drupal version, set up in early 2013, custom Zen Subtheme). When I create a new Content Type with a new Field Type "Image" this 'Number of values' pulldown isn't showing up where it should. I've now spent the whole day researching how this could be, without any luck.

Screenshot

I've tried default themes, checked user permissions and also file permissions (while always rebuilding the theme registry). I googled around for hours but I couldn't find any clue how to fix this .

What could be the reason for this?

Any tips for further testing are welcome.

Edit:

  • The field value is internally called cardinality.
  • The problem seems to affect all field types of this installation.
4
  • Because your screen is using the admin theme your normal theme is not relevant but the admin theme you are using is.
    – rooby
    Dec 19, 2014 at 21:18
  • If you look in the markup of the page (view source in your browser or using firebug or other similar developer tools) is the field there, but hidden, or not there at all?
    – rooby
    Dec 19, 2014 at 21:20
  • If you submit that form do you get any errors?
    – rooby
    Dec 19, 2014 at 21:20
  • Admin theme is Seven. It's the same as on another site of mine that doesn't have the problem. In the markup the field is not there. No errors on screen or in logs.
    – AAGD
    Dec 19, 2014 at 21:28

1 Answer 1

2

Answering my own question:
I tracked down the bug by disabling module by module and finally found out that disabling the Gigya - Social Infrastructure module was bringing back the form fields.

Fortunately the issue was already listed and solved five days ago!

Not the answer you're looking for? Browse other questions tagged or ask your own question.