0

I'm having no luck with sql-sync, there's two seemingly unrelated errors it's throwing at me which I'll detail below.

I've been successfully sql-sync'ing the same site to another server, so I'm pretty sure it's the remote server, not the local server, that is causing the problems. The remote server MySQL version is: 5.6.19-0ubuntu0.14.04.1 (Ubuntu)

1) Adding the --create-db switch gives me:

ERROR 1044 (42000) at line 1: Access denied for user 'user'@'localhost' to database 'database'

2) Regardless of whether or not I use the --create-db switch, I always get this:

ERROR: ASCII '\0' appeared in the statement, but this is not allowed unless option --binary-mode is enabled and mysql is run in non-interactive mode. Set --binary-mode to 1 if ASCII '\0' is expected. Query: '��T'.

Any ideas?

  • Can you post the output of the command using the -v flag? – webkenny Dec 22 '14 at 19:01
2

So it turns out I'd installed Drush 6 on the remote server, while my local version was Drush 7. Upgrading solved the problem.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.