1

I'm running a apache2 server on Ubuntu. While I was in the middle of configuring new content on my local instance of drupal via Firefox, the site suddenly stopped working. My first thought was the the apache2 server was down, so I restarted it. Then I created an index.html, and index.php that both worked (outside the drupal directory).

Now let's say I go to localhost/drupal/ I get a blank page. However, if I go to localhost/drupal/update.php I get the update page. I found that out as I was trying to figure out if any page would load. /index.php does not work.

Any idea to what I should investigate next? What's weird is that I was in the middle of working on the site when it went down. I don't see a reason for that to happen.

Any help is appreciated.

Thank you!

Update: I found that apache log can be handy. By typing into the terminal:sudo cat /var/log/apache2/error.log

I found that the log had the following error:

PHP Fatal error:  Cannot redeclare class QueryConditionInterface in /var/www/html/drupal/includes/database/query.inc on line 16

I tried replacing this file with the file from the original drupal package, didn't work. Nor should it have because I didn't change any code in this file.

Things I've tried:

  • Restart mysql and appache2 using sudo service mysql restart
  • Delete /drupal/includes/ and re-populate it with files from the original

    package.

0

Sounds like it can't connect to the database any more if it's crashing on /query.inc

Some things to try:

  • Check your database daemon is running (sudo service mysql status or similar)
  • Check that your settings file has the correct db information and permissions
  • Check that your drupal user in mysql has right level of permissions (and that it exists)
  • - mysql is running - settings file in ~/var/www/html/drupal/sites/default/settings.php are correct - the drupal user exists and has the permission I was in the middle of creating contents on the site, while it went down. That's why it doesn't make sense. It was working until it randomly stop. – newdimension Dec 21 '14 at 23:36
  • Try restarting mysql, maybe a table is locked. – Darvanen Dec 21 '14 at 23:38
  • I agree that is seems mighty strange – Darvanen Dec 21 '14 at 23:39
  • restarted apache and mysql using sudo service mysql restart – newdimension Dec 21 '14 at 23:40
  • Hm, ok maybe have a look at this and this – Darvanen Dec 21 '14 at 23:59
0

I deleted all files, and dropped the database, then re-did the site. The problem was probably because I mixed and matches between an installation profile and the original package files.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.