1

I'm trying to list all duplicate nodes based on node title with views.

In views aggregation settings it's said that:

If enabled, some fields may become unavailable. All fields that are selected for grouping will be collapsed to one record per distinct value. Other fields which are selected for aggregation will have the function run on them. For example, you can group nodes on title and count the number of nids in order to get a list of duplicate titles.

I enabled aggregation and added a node content title filter (aggregation: count) to count nodes and list if a title has more than one node (count: Is greater than 1). But it doesn't work for me, it lists nodes with unique titles and duplicate titles (I mean no affect).

How can I list all nodes with duplicate titles by using views?

2

The filter should be on content:nid. Set it to aggregate on COUNT, and 'Is greater than' value 1.

Then check all of your fields that you have added. None of the fields for nodes with the same title should output a different value. Title for instance, can be unique, depending on how you output it. If you for instance output it as a link (the default), then for each title that is the same, but that belongs to another node, the link is unique, therefore you view won't perform the way you want it to. So deselect 'Link this field to the original piece of content' and it should work.

  • Thanks but unfortunately this didn't work. I had only one field active (content: title) and deselected 'Link this field to the original piece of content'. Added a filter content:nid with COUNT and 'Is greater than' 0 (and I tried 1, too). Didn't work. – herci Dec 24 '14 at 19:54
  • Strange as it works on my side. Do you have any Sorts on the view. If so remove them, test the view, then add them again as sorting can give issues. – J. Reynolds Dec 25 '14 at 6:44
  • Interestingly it's working now (after creating a new views from zero). But with 'Is greater than' value 1. Please update your answer then I can mark as answer. Thanks again. – herci Dec 28 '14 at 17:13
  • 1
    @herci Glad to hear. When enabling aggregation mid-stream in a view it sets defaults to fields and filters that you probably do not want. So you either have to revisit all the aggregation settings, or start from scratch. – J. Reynolds Dec 28 '14 at 17:39

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.