0

I created an entity with date field. Currently the date is being output in the format "mm/dd/yyyy":

enter image description here

How can I use the format "dd.mm.yyyy"? I couldn't find any settings, related to it, in the field configuration form.

0

You can usually only change the output of a date field, as it is easier to convert an existing date to something else. The input is often standardised to make sure the system understands the input.

In order to change the output, create a new date format admin/config/regional/date-time/formats and enable it on admin/config/regional/date-time. Then you can use it as a display for the field on the display tab.

1
  • No, it didn't work. I found, how to set the format through the field advanced settings. – user4035 Dec 26 '14 at 7:24
0

The format can be changed in the settings of the field. You need to:

  1. Click "More settings and values"
  2. Select "Custom format" in Date entry options
  3. Insert the format: "d.m.Y"

enter image description here

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.