1

I have a paragragh which has 3 font colors throughout it, however every time I try to add the spans inside the paragraph CKEditor takes it upon it's self to remove them on me. How do I get the spans to stay inside the paragraph?

I save this:

<p>Have <span class="lt-blue-txt">TROUBLING SYMPTOMS</span> and health concerns taken over your life? <span class="white-txt">Muse can help</span>.</p>

but it turns into this:

<p>Have TROUBLING SYMPTOMS and health concerns taken over your life? Muse can help.</p>
0

Did these links not help:

https://stackoverflow.com/questions/18349048/ckeditor-strips-span-and-style-attributes

"If you are using the CKeditor module then there is an option in Advanced Options that is also mentioned in the module homepage where you should set"

or: Prevent WYSIWYG+CKEditor from stripping html classes "There is an issue with CKEditor 4.1+, which has a feature called Automatic Content Filter (ACF) that will automatically strip attributes not defined for the editor"

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.